Back to overview
Maintenance

Scheduled System Upgrade

Jun 2, 2026 at 9:00am UTC  –  Jun 4, 2026 at 1:52pm UTC
Affected services
Website
Platform

Resolved
Jun 4, 2026 at 1:52pm UTC

Maintenance ended

Updated
Jun 4, 2026 at 1:52pm UTC

Maintenance is complete.

Thank you for your patience during the update!

Created
Jun 2, 2026 at 9:00am UTC

We’re performing a scheduled upgrade of our platform as we migrate to our next-generation system.

During this maintenance window, users may experience brief service interruptions or degraded availability across our web and mobile applications. We’re working to complete the upgrade as smoothly as possible and will update this page once everything is back to normal.

This upgrade is part of our ongoing work to improve reliability, performance, and the overall product experience.